Messages to leads not sending
Incident Report for Intercom
Resolved
This incident has been resolved.
Posted about 2 months ago. Aug 02, 2019 - 08:59 UTC
Update
We have backfilled and resent broken email and in-app messages impacted during the period ~29-07-2019 1443 UTC to 01-08-2019 0724 UTC.
Posted about 2 months ago. Aug 01, 2019 - 18:05 UTC
Update
Due to a bad code deploy, emails and in-app manual messages targeted at leads wouldn't send between ~29-07-2019 1443 UTC to 01-08-2019 0724 UTC. We have rolled out a fix and manual messages targeted at leads are sending as expected again.

This affected messages sent from a lead's profile via the "Start a conversation" button or when messaging leads by selecting them under "Platform". Admin-initiated conversations for leads via the API were also affected.

We're investigating backfilling messages sent during the period.

This did not affect manual messages created under "Messages" and auto messages targeted at leads weren't affected either.
Posted about 2 months ago. Aug 01, 2019 - 07:33 UTC
Identified
We have identified that emails or in-app messages sent to leads from their profile using the "Start a conversation" button or by selecting leads under "Platform" aren't sending.

We have identified the bad deploy and are reverting the change.
Posted about 2 months ago. Aug 01, 2019 - 06:38 UTC
Investigating
We are currently investigating reports of messages not sending to leads.
Posted about 2 months ago. Aug 01, 2019 - 05:42 UTC