Degraded performance for Intercom Application
Incident Report for Intercom
Resolved
This incident has been resolved.
Posted Oct 18, 2019 - 23:51 UTC
Update
We have identified a query that was causing degraded performance, and have since shipped the appropriate changes to relieve the resulting issues.

There should no longer be any negative impact on:

* Inbox performance and conversation load time
* Operator's responsiveness
* Email or push notifications
* Conversation webhook delivery
Posted Oct 18, 2019 - 23:27 UTC
Update
We are continuing our investigation into the degraded performance for the Intercom application.

Conversation services are the most impacted by this degradation and customers may experience:

- Degraded inbox performance when loading conversations or switching inboxes
- Operator taking longer to engage with conversations
- Delayed email and push notifications for replies to conversations by 2 - 3 minutes
- Delayed conversation webhook notification deliveries
Posted Oct 18, 2019 - 21:59 UTC
Investigating
We are currently investigating reports of degraded performance in the Intercom Application.
Posted Oct 18, 2019 - 21:02 UTC
This incident affected: Intercom Web Application, Intercom Webhooks and Intercom message delivery (Admin notifications).