Inbox Reports
Incident Report for Intercom
Resolved
We have identified the issue with our Inbox Reports and those pages are operating as normal again.
Posted 4 months ago. Apr 27, 2018 - 17:31 UTC
Investigating
We are looking into an issue where Inbox Reports are not loading correctly in our web app.
Posted 4 months ago. Apr 27, 2018 - 16:36 UTC
This incident affected: Intercom Web Application.