Email delivery is experiencing delays due to an upstream vendor outage
Incident Report for Intercom
Resolved
This incident has been resolved. All delayed emails have been processed and delivered.
Posted 27 days ago. May 24, 2019 - 02:08 UTC
Monitoring
Between 2019-05-23 2222 UTC and 2019-05-23 2336 UTC, outbound emails and admin email notifications experienced a delay in delivery time. This was due to a partial outage from our upstream email delivery provider.

The issue was resolved by our upstream provider and new email messages and admin notifications are now sending on-time.

Emails that were delayed by this issue are queued to send shortly and we are closely monitoring the sending status.
Posted 27 days ago. May 24, 2019 - 00:17 UTC
Identified
We have identified that the issue with email delivery being delayed is a result of a partial outage from our upstream email delivery provider. We have identified that links within emails are not impacted by this issue as previously reported. Links continue to work as expected.
Posted 27 days ago. May 23, 2019 - 23:27 UTC
Investigating
Email deliveries are experiencing delays and links within emails are experiencing redirect issues. We are currently investigating this issue with our upstream email delivery provider.
Posted 27 days ago. May 23, 2019 - 23:01 UTC
This incident affected: Intercom message delivery (Small message delivery, Medium message delivery, Large message delivery, Admin notifications).