Higher than normal latency on Intercom
Incident Report for Intercom
Resolved
This incident has been resolved.
Posted Nov 12, 2021 - 16:50 UTC
Update
We are continuing to investigate this issue.
Posted Nov 12, 2021 - 16:30 UTC
Investigating
We are currently seeing higher than normal latency across parts of Intercom.

This includes delayed email processing, message sending, admin notifications, and updates of Inbox Views.
Posted Nov 12, 2021 - 16:23 UTC
This incident affected: Intercom message delivery (Email, Chats and Posts, Admin notifications) and Intercom Web Application.