Email Attachment Issues.
Incident Report for Intercom
Resolved
Due to recent incidents with some urls in emails to Gmail / G-Suite being flagged as "malicious", engineering teams have continued to work on root causes of this issue, improving anti-virus scanning and limiting the impact of potential future events.

As a result of this work, files linked in notification emails with the following extensions will no longer be directly downloadable from notification email but will still be available in the Inbox product:

doc, docx, xlsx, docm, xlsm, img, exe, html, htm, php, js, zip, gz, 7z, rar, z, zls, tar

Attachments of other filetypes will still be linked in email. Attachments to normal outbound email from the Messages product are not affected by this change.

If you have further questions about this, feel free to get in touch with our team at team@intercom.io
Posted 3 months ago. May 30, 2019 - 14:23 UTC
Identified
As a followup to our previous incident, we are still preventing the download of certain attachment file types originating from inbound email but we have made a change to allow the .docx format through our filters.

However, the following file types are still temporarily prevented.

_doc, xlsx, docm, xlsm, img, exe, html, htm, php, js, zip, gz, 7z, rar, z, zls, tar_

We have also introduced a change to only block attachments if they are attached to the first inbound email message, instead of all replies, this way customers will be able to see attachments in replies to conversations, but not if they are included in the first inbound email message.

The files are still stored, but we have blocked access. We are currently looking into ways to safely restore access to these file types without causing reputation issues with major inbox providers such as Google.
Posted 3 months ago. May 27, 2019 - 12:29 UTC
This incident affected: Intercom message delivery (Small message delivery, Medium message delivery, Large message delivery, Admin notifications).