Updates to user data is experiencing significant delays
Incident Report for Intercom
Resolved
Between 2020-03-31 1614 UTC and 2020-03-31 1949 UTC, Intercom customers may have experienced significant delays in the processing of updates to user, lead, or company data.

During this time, customers may have experienced issues relating to the people or company search operation.

Impacted features that use this operation include API requests, App Store apps (i.e. Slack app), filtered people or company list, audience previews for outbound messages, people or company profile views, conversation search by user, campaign and message matching, and segment membership updates.

We have resolved the issue and have finished processing the backlog of data updates. Data update processing is back to normal and all services are fully operational.
Posted Mar 31, 2020 - 22:14 UTC
Identified
We have identified the issue leading to the delayed updates and we are processing the backlogged queue. You may experience inconsistent results when searching for or listing users, leads, or companies while we process this backlog.
Posted Mar 31, 2020 - 20:59 UTC
Investigating
Beginning on 2020-03-31 at approximately 1600 UTC, we started investigating an issue where user data updates are experiencing significant delays in processing.
Posted Mar 31, 2020 - 19:34 UTC
This incident affected: Intercom Web Application.