Intercom Phone functionality degraded
Incident Report for Intercom
Resolved
Twilio have closed out this incident on their status page and we have confirmed that functionality for Intercom phone has returned to normal.
Posted Apr 22, 2024 - 18:07 UTC
Update
We are continuing to wait on confirmation from Twilio about full service recovery.
Posted Apr 22, 2024 - 17:25 UTC
Identified
Our downstream provider, Twilio, is experiencing an outage which impacts Phone functionality. We will continue to monitor their status page for recovery.
Posted Apr 22, 2024 - 16:21 UTC