Inbox functionality degraded
Incident Report for Intercom
Resolved
This has been resolved.
Posted Apr 22, 2024 - 15:20 UTC
Monitoring
We have shipped a fix for this and are monitoring its effectiveness.
Posted Apr 22, 2024 - 15:05 UTC
Identified
We are having issues with the Inbox, where hovering over the left hand sidebar can cause the entire Inbox to become unresponsive. We have identified the issue and are working on a fix.
Posted Apr 22, 2024 - 14:57 UTC
This incident affected: Intercom Web Application.