Delays in data being populated in reports
Incident Report for Intercom
Resolved
The issue has been resolved and the data is now up-to-date.
Posted Jun 03, 2024 - 20:18 UTC
Monitoring
We have implemented a fix and are monitoring for recovery.
Posted Jun 03, 2024 - 19:18 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jun 03, 2024 - 17:30 UTC
Identified
We're experiencing some delays in new data being populated in our reports. We have identified the issue and are working to resolve it.
Posted Jun 03, 2024 - 17:11 UTC