Stale data in Users Search
Incident Report for Intercom
Resolved
At 10.50pm UTC we successfully completed processing the user data backlog, user search data is no longer stale.
Posted Jun 13, 2023 - 22:52 UTC
Update
At 10.50pm UTC we successfully completed processing the user data backlog, user search data is no longer stale.
Posted Jun 13, 2023 - 22:51 UTC
Update
At 10.50pm UTC we successfully completed processing the user data backlog, user search data is no longer stale.
Posted Jun 13, 2023 - 22:51 UTC
Update
Affected AWS services have recovered, we are monitoring as we start to ingest user data again.
Posted Jun 13, 2023 - 21:32 UTC
Update
We continue monitoring the ongoing AWS outage: https://health.aws.amazon.com/health/status

At the moment we have not detected any additional impact on our services.
Posted Jun 13, 2023 - 20:15 UTC
Update
We are continuing to monitor possible degraded performance across our product as AWS expanded the list of affected services: https://health.aws.amazon.com/health/status
Posted Jun 13, 2023 - 19:49 UTC
Investigating
We are monitoring an AWS outage that is causing our Users Search data, in particular data will be stale when:

- Searching for users in the Teammate app
- In User Segments in the Teammate app
- In the Matching system (ex. sending outbound messages to users that no longer match filters)
- In the Contacts API

We will update as the situation evolves.
Posted Jun 13, 2023 - 19:30 UTC
This incident affected: Intercom Web Application and Intercom APIs.