Inbound Email Attachment Issues
Incident Report for Intercom
Resolved
Between 2019-06-14 and 2019-06-17, customers would have experienced issues with Attachments in Intercom, in both in-app conversations, and emails. This was due to engineering work undertaken to prevent the reoccurrence of emails being sent via Intercom being flagged as "malicious" when sent to Gmail or GSuite hosted email addresses.

As part of the work performed, we now only allow download of the following filetypes from Intercom by default:
.pdf, .png, .jpg, .gif, .txt

For customers who require the use of additional filetypes, you can add custom filetypes to be supported on your Intercom Workspace. This is available to set by Intercom Teammates who have Full-Access permissions, and can be done here: https://app.intercom.io/a/apps/_/settings/attachment-settings.

File attachments that are sent via Email will now render the link for new email sent. There is one exception to this - if a new conversation is created using email, and that email contains an attachment that is not part of the receiving workspaces's whitelisted filetypes, notification emails sent as a result of this will not link to the file due to it not being whitelisted.

This incident is now resolved and all services are working as expected.
Posted 3 months ago. Jun 18, 2019 - 16:44 UTC
Update
Here is an update on the current status of attachments in Intercom.

At the moment, we continue to block attachments from being downloaded via Intercom in certain scenarios.

In email - we are not rendering the link to attached files of any type, for all email sent via Intercom. This includes links sent into Intercom customer workspaces, as well as emails sent from Intercom customer workspaces.

In the Inbox product - we are allowing all files to be uploaded, but only files with the following extensions are available for download by default:
.pdf, .png, .jpg, .gif, .txt

However - for customers impacted by this restriction, you can add custom filetypes to be supported on your Intercom Workspace. This is available to set by Intercom Teammates who have Full-Access permissions, and can be done here: https://app.intercom.io/a/apps/_/settings/attachment-settings.

Whitelisted filetypes should be accessible straight away. If you have any trouble accessing files after you have whitelisted them, please get in touch with our Intercom Support team by using the Messenger while you're logged into Intercom. We have also created a new Help Center article here that explains this too - https://www.intercom.com/help/articles/3074152-unsupported-attachment-filetypes

In addition to this - we have shipped a new error page for users affected by downloads being blocked which explains that the file is blocked due to being an unsupported file type.
Posted 3 months ago. Jun 17, 2019 - 13:00 UTC
Update
As an update to our efforts to mitigate this issue, we are now allowing only specific filetypes to be accessible as attachments:

- .pdf, .png, .jpg, .gif, .txt

While attachments will not be accessible via email, customers will see attachments available in the Inbox and only the filetypes listed above will be accessible by default.

For customers who might still see these filetypes being blocked from download specifically by the Google Chrome browser, using another browser should allow these files to be downloaded.

We have also added a new settings page which will allow you to add additional filetypes to be allowed for your workspace. You can find that settings page here: https://app.intercom.io/a/apps/_/settings/attachment-settings
Posted 3 months ago. Jun 14, 2019 - 18:43 UTC
Update
As an update to our efforts to mitigate this issue, we have blocked downloads of all attachment types apart from PDFs, Images and Videos. Customers will see attachments available in the Inbox but those files will be inaccessible.

For customers who might still see PDFs, Images or Videos being blocked from download specifically by the Google Chrome browser, using another browser should allow these files to be downloaded.

This is a temporary restriction in place to aid our engineering efforts to solve the root cause of this issue.
Posted 3 months ago. Jun 14, 2019 - 10:23 UTC
Update
We are continuing to monitor for any further issues.
Posted 3 months ago. Jun 14, 2019 - 00:23 UTC
Update
We are continuing to work with Google services to improve and maintain our sending quality. Due to this ongoing work, we have temporarily prevented direct access to attachments from emails sent from within Intercom workspaces.

Any workflows that rely on directly linked attachments in emails coming from Intercom will be temporarily disrupted.

The list of filetypes that will be impacted by this are:
- doc, xslx, docm, docx, xlsm, exe
- html, htm, php, js
- zip, gz, 7z, rar, z, zls, tar
- arj, iso, ace, apk
- IMG, img, uue, cab
- gz, jar, vb, vbe, bat, hta, py, sfx
- msi, msp, com, cmd, jse, ps1, ps1xml
- ps2, ps2xml, psc1, psc2, lnk, inf, scr, sh


Attachments will still be accessible while in the Intercom web application as expected. Google Chrome may temporarily prevent downloading certain filetypes.
Posted 3 months ago. Jun 13, 2019 - 23:26 UTC
Monitoring
We are working with Gmail and GSuite services to improve and maintain our sending quality.

Workflows that rely on receiving inbound email attachments coming into Intercom will be temporarily disrupted.
Posted 3 months ago. Jun 13, 2019 - 18:39 UTC
This incident affected: Intercom Web Application.