Billing Settings page not updating customer information
Incident Report for Intercom
Resolved
From 2018-11-07 2315 UTC to 2018-11-08 0921 UTC, customer would have experienced issues with updating their billing settings due to an integration issue on the Billing system. This issue has now been resolved and customers can now successfully update their billing information.
Posted 11 days ago. Nov 08, 2018 - 09:39 UTC
Investigating
We are currently investigating an issue with the Billing Settings page that is preventing customers from updating their Billing information.
Posted 11 days ago. Nov 08, 2018 - 09:23 UTC
This incident affected: Intercom Web Application.