Fin performance degraded
Incident Report for Intercom
Resolved
Fin performance is back to normal, issues have been resolved.
Posted Aug 25, 2023 - 16:49 UTC
Investigating
We are currently experiencing issues that are affecting the performance of Fin. We are monitoring the situation and will provide updates here.
Posted Aug 25, 2023 - 16:03 UTC
This incident affected: Intercom Messenger (Web Messenger, Mobile Messenger) and Intercom Web Application.