We have reverted a bad code deploy which affected background job processing in all our regions. This error would have caused general delays and latencies across most feature of Intercom, including conversation assignment, automated support features such as Fin, Operator, and email sending. This issue is now resolved and all services are working as expected.
Posted Sep 20, 2023 - 17:30 UTC
Investigating
We are investigating issues with background worker processing of jobs affecting multiple services across all Intercom regions
Posted Sep 20, 2023 - 17:38 UTC
This incident affected: Intercom message delivery (Email, Chats and Posts, Mobile Push, Admin notifications), Intercom Messenger (Web Messenger, Mobile Messenger), Intercom Europe (Intercom Web Application, Intercom Web Messenger, Intercom Mobile Messenger, Intercom APIs, Intercom Webhooks), Intercom Australia (Intercom Web Application, Intercom Web Messenger, Intercom Mobile Messenger, Intercom APIs, Intercom Webhooks), and Intercom Web Application, Intercom APIs, Intercom Mobile APIs.