Delays in outbound email sending
Incident Report for Intercom
Resolved
A backlog has been processed and email delivery is back to normal.
Posted May 03, 2024 - 10:15 UTC
Identified
Intercom is experiencing delays in outbound email delivery. We're working on it!
Posted May 03, 2024 - 09:26 UTC
This incident affected: Intercom message delivery (Email).