The maintenance has been completed and all delayed emails, messages, and notifications are being re-driven.
Posted Oct 07, 2023 - 08:24 UTC
Verifying
The upgrades have completed. We're verifying system operations.
Posted Oct 07, 2023 - 08:15 UTC
Update
We're seeing clusters completing the maintenance and will now start to see recovery.
Posted Oct 07, 2023 - 08:04 UTC
Update
One set of database clusters remains in the upgrading state. We are monitoring it's progress. We have extended the window by 30 minutes to account for this.
Posted Oct 07, 2023 - 07:53 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 07, 2023 - 07:01 UTC
Scheduled
Between 2023-10-07 07:00 UTC and 2023-10-07 08:00 UTC, customers based in the US data hosting region will experience a series of interruptions to all features.
What is the impact? During the maintenance window, Intercom features will be degraded or unavailable for up to 20 minutes.
Customers using our European and Australian Regional data hosting will not be impacted.
Why are we doing this? Some of our database clusters need to be restarted during the maintenance window while we perform an important database update.
Customer trust, data security, and availability are critical to everything we do at Intercom. We only do these essential maintenance tasks when absolutely necessary, and always give at least 48 hours notice.
What will the exact experience be for our customers during the change? During the changes, the following may occur: • Customers using the US data hosting region will see degraded performance across Intercom. • Processing of emails, messages, and notifications will be delayed for several minutes.
Posted Oct 03, 2023 - 15:57 UTC
This scheduled maintenance affected: Intercom message delivery (Email, Chats and Posts, Mobile Push, Admin notifications), Intercom Messenger (Web Messenger, Mobile Messenger), and Intercom Web Application, Intercom APIs, Intercom Mobile APIs, Intercom Webhooks.