Slow inbox
Incident Report for Intercom
Resolved
This incident has been resolved.
Posted May 14, 2024 - 14:38 UTC
Update
We are continuing to investigate this issue.
Posted May 14, 2024 - 14:15 UTC
Investigating
We are investigating reports that Inbox is slow.
Posted May 14, 2024 - 13:59 UTC
This incident affected: Intercom Messenger (Web Messenger) and Intercom Web Application.