New Trial Issue
Incident Report for Intercom
Resolved
This incident has been resolved.
Posted 11 days ago. Aug 09, 2018 - 16:38 UTC
Investigating
We're looking into an issue where a certain subset of customers are unable to start a new trial.
Posted 11 days ago. Aug 09, 2018 - 13:31 UTC
This incident affected: Intercom Web Application.