Inbox not loading for some customers
Incident Report for Intercom
Resolved
This incident has been resolved.
Posted Mar 02, 2023 - 15:52 UTC
Update
We have identified the root cause and the incident was resolved at 15:35 UTC
Posted Mar 02, 2023 - 15:52 UTC
Investigating
We are investigating reports of high latency and/or Inbox not loading for some customers, we will follow up with updates as the situation evolves.
Posted Mar 02, 2023 - 15:39 UTC
This incident affected: Intercom Web Application.