GSuite and Gmail email delivery issues related to files being flagged as "dangerous"
Incident Report for Intercom
Resolved
This incident has been resolved. Google's review of our infrastructure was successful and they no longer report banners or unsafe downloads for our domain. We will keep certain attachments blocked on inbound email (replies to conversations by email or email forwarded to us) for the time being, until we investigate changes to our anti-virus scanning for inbound email
Posted 25 days ago. May 25, 2019 - 22:39 UTC
Monitoring
We are continuing to monitor this situation for resolution; at this time we are awaiting review from Google to remove the banner from emails sent via Intercom. In parallel, we also continue to work on multiple engineering tracks to resolve this issue and minimise the chance of reoccurrence. At this time we have no ETA on the completion of the Google review, but will update this incident on any status changes.
Posted 26 days ago. May 25, 2019 - 11:12 UTC
Identified
We have identified the source of the email delivery issues, related to customer files sent via Intercom being flagged as malicious by Google.

In order to resolve this issue and restore email delivery back to expected levels more quickly, we will temporarily prevent the download of attachments that were created through emails coming into Intercom workspaces which match any of the filetypes in the list below.

Workflows that rely on receiving inbound email attachments coming into Intercom will be temporarily disrupted while we're implementing this fix.

Attachment filetypes that are temporarily prevented include:
- doc, xslx, docm, docx, xlsm, exe
- html, htm, php, js
- zip, gz, 7z, rar, z, zls, tar
- arj, iso, ace, apk
- IMG, img, uue, cab

The status of this event will be updated directly at this url: https://www.intercomstatus.com/incidents/1fgmlkrmwnzd
Posted 26 days ago. May 24, 2019 - 21:46 UTC
Investigating
We are investigating email delivery issues related to customer files sent via Intercom being flagged as malicious by Google.

Known Impacted Email Services include:
- Auto, Campaign, and Manual Emails sent via Messages to GSuite or Gmail addresses.

Email Services Not Impacted:
- Transactional emails sent from Intercom itself
- Conversation summaries from Inbox conversations
- Emails sent via Messages to non Gmail or GSuite addresses
Posted 26 days ago. May 24, 2019 - 20:04 UTC
This incident affected: Intercom message delivery (Small message delivery, Medium message delivery, Large message delivery, Admin notifications).